Data Flow Task:Error: System.InvalidCastException: Unable to cast COM object of type 'System.__ComObject' to interface type 'Microsoft.SqlServer.Dts.Pipeline.Wrapper.IDTSComponentMetaData100'.

Mar 4, 2016 at 9:48 AM
I've build a project to retrieve data from GA. In VS it is working fine in debug mode. But when I try it on SQL server i get the error:

Data Flow Task:Error: System.InvalidCastException: Unable to cast COM object of type 'System.__ComObject' to interface type 'Microsoft.SqlServer.Dts.Pipeline.Wrapper.IDTSComponentMetaData100'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{887BD061-82D4-4F06-A222-337D42E7F896}' failed due to the following error: No such interface supported (Exception from HRESULT: 0x80004002 (E_NOINTERFACE)).
at System.StubHelpers.StubHelpers.GetCOMIPFromRCW(Object objSrc, IntPtr pCPCMD, IntPtr& ppTarget, Boolean& pfNeedsRelease)
at Microsoft.SqlServer.Dts.Pipeline.Wrapper.IDTSComponentMetaData100.get_RuntimeConnectionCollection()
at SSISComponents.GoogleAnalyticsSource.AcquireConnections(Object transaction)
at Microsoft.SqlServer.Dts.Pipeline.ManagedComponentHost.HostAcquireConnections(IDTSManagedComponentWrapper100 wrapper, Object transaction)

The Data Source Component is installed on the server.
What can be wrong?
Mar 7, 2016 at 10:48 AM
I've found it! I was working om VS2012 on a MSSQL2014 database. For 2014 you have to use VS2013.
Jun 22, 2016 at 5:16 PM
Edited Jun 22, 2016 at 5:17 PM
Can you please post the steps you followed to work this ? I tried to move my VS2012 packages to VS 2013. It did not recognize GA source at all, though I have GA source on VS 2013 insatlled
Jun 24, 2016 at 7:53 AM
Hi Jahnavi

The transforms are different. The VS2012 transform works on a SQL2012 database. The VS2013 transform works on a SQL2014 database.
I had to rebuild the package. :-(
Jun 24, 2016 at 7:55 PM
I rebuilt the package in VS 2013 and deployed it on sql server 2014. I still run into errors.

Data Flow Task:Error: The managed pipeline component "SSISComponents.GoogleAnalyticsSource, SSISComponents.Dts.Pipeline.GoogleAnalyticsSource2014, Version=1.7.0.0, Culture=neutral, PublicKeyToken=1eab8a67122c49ca" could not be loaded. The exception was: Could not load file or assembly 'SSISComponents.Dts.Pipeline.GoogleAnalyticsSource2014, Version=1.7.0.0, Culture=neutral, PublicKeyToken=1eab8a67122c49ca' or one of its dependencies. The system cannot find the file specified.

Do you know what this error is and how to resolve?
Jun 27, 2016 at 2:17 PM
What version of SQL server are you using? The GA transform in VS2013 wil only work on SQL2014
Aug 31, 2016 at 4:14 PM
Edited Aug 31, 2016 at 4:39 PM
Can you please be more specific please ? I am confused here. I have visual studio 2013 , Google analytic source 2012 and sql server 2014. Which version of google analytics will work for the one Visual studio 2013 /sql server 2014 and which version of google analytics work for Visual studio 2012/Sql server 2014?

If you don't mind to be more clear and specific , please provide Google analytics source link with the version you mentioned that works ?
Sep 1, 2016 at 3:34 PM
Just an update :

I was able to figure it out :

GA source 2014 msi works in VS 2013 On sql server 2014.


When I try to install GA source 2012 msi on Visual studio 2013 ...it is not showing up in data flow task ( hence figured that GA 2012 msi wont work in VS 2013).

As you said : GA source 2012 msi works only in VS 2012 but wont work on SQL server 2014.

Another issue is that it was working when i run through SSISDB but not when I schedule as a job. Figured out that the sql server agent has no proper permissions to access the folder where .xml files are located. I have to change the SQlServeragent service account to logon as a "local ssytem" to acess the folder where the .xml files are residing.

Finally was able to automate the entire process :)

But My company wanted to upgrade to sql server 2016 and aslo upgarde to VS 2015 or VS 2013 in future. So , my question is can we still make it to run successfully? on these vs 2015 and sql server 2016 versions?
Sep 5, 2016 at 1:02 PM
I've tried to get de GA source to work on VS2015 but it did'nt. I've stopped using it since it not really been supported anymore...
You can give the Targit GA source a try:

https://www.targit.com/en/resources/store/datareaderforgoogleanalytics
Sep 6, 2016 at 3:06 PM
Is it a freeware?