Google Analytics 2008 Login Issue

Jun 1, 2015 at 2:33 PM
Hi ,

We are using Google Analytics Source Task in Visual studio 2008 for more than 6 months.
From Yesterday not able to connect to the Google Analytics. But Able to Login to Google Analytics Account and view the data.
We tried to install the 2012 component in the visual studio 2012 trial version its working fine.
Is this issue with Google Analytics Source Task 2008.
After giving the credentials, If I click on test It shows the Error "Connection Could not be established"
If I click on Login ,"System.Net.Webexception: remote server returned an error :(404) Not Found.
at System.Net.HttpWebrequest.GetResponse()
at SSIS Components.frmGoogleAnalyticsSource.connect(strin UserName, string password, Boolean Raise Error)
at SSIS Components.frmGoogleAnalyticsSource.btnLogin_Click(ObjectSender, EventArgs e)."
But the same SSIS package was executed fine to Load the data to table for past 6 Months

Please let me know any suggestion. Thanks in Advance.

Regard,
Suresh Kumar T
Jun 1, 2015 at 6:52 PM
Hello,

I am also receiving this error. It started on 5/27/15.

Sorry to not supply an answer to this issue, but I figured the info I received on it would help point someone more knowledgeable in the right direction.

On this discussion board, there are threads from 2012 that mention a similar issue (https://analyticssource.codeplex.com/discussions/393381), but it is strange the it is coming up again so many years later. I asked a colleague in our company who is a Sr. Web System Programmer and he said both the "Old" and "New" feed locations were up and running and received a 401 error when logged into Google Analytics on the same browser. As found online (https://developers.google.com/analytics/devguides/reporting/core/v2/), the feed locations are as follows, collected from here:
Old – https://www.google.com/analytics/feeds/data
New – https://www.googleapis.com/analytics/v2.4/data

This page: https://developers.google.com/identity/protocols/OpenID2Migration, states in big red that OpenID 2.0 is no longer supported and OpenID Connect is the future as we know it. This may be the underlying issue.

I hope this points someone in the right direction.

Thanks for any help anyone can provide.
Jun 2, 2015 at 8:32 AM
Edited Jun 2, 2015 at 8:32 AM
Same issue on the 2008 version - I had a job running every 30 minutes so the failure happened between 7:30pm and 8:00pm British Summer Time on the 26th May 2015. I've raised the issue with google support and have some back and forth with them - will feedback if they come back with anything useful.
Jun 2, 2015 at 10:25 AM
Please let me know any alternate solution for this issue.

Thanks,
Suresh Kumar T
Jun 2, 2015 at 2:18 PM
Adding my name to the list: We've got the exact same error messages from a package which runs weekly- it worked fine last Tuesday, but is failing today. Currently using v1.2 of the add-in and have been for a couple of years- great work by the developers!

If anyone works out a fix, it would be greatly appreciated if you could post it back here.

Thanks,

Tom
Coordinator
Jun 2, 2015 at 2:36 PM
Hi all,

I assume that Google has shut down the API.
Please use the newer versions of the component (only SQL Server 2012/2014) which supports OAuth.

I will check if I can implement OAuth in the component for SQL Server 2008. But that takes some time.

Cheers,

Tillmann
Jun 2, 2015 at 3:19 PM
Thanks for the quick response- I'll try the more up to date versions.

Cheers,

Tom
Jun 2, 2015 at 3:25 PM
Hello,

I've the same issue on the 2008 version but I can't upgrade version. It worked well until last week

¿Some alternate solutions on SQLServer 2008?


Thank you very much

Kiko
Jun 3, 2015 at 4:38 AM
Thank You Tillmann. We are still using Integration Service 2008.
So we are not able use the 2012/2014. It would be helpful If you provide any alternate solution or fix for this.


Regards,
Suresh Kumar T
Jun 9, 2015 at 7:29 AM
Hi,

I'm hopping on to this thread as we're having the same issue and also not able to upgrade our SQL server just yet. An alternative solution for this would be extremely good.

Look forward to hearing back from you Tillmann, or anyone else with a SQL 2008/2008R2 solution.

Thanks
Shona
Jun 11, 2015 at 9:31 AM
The same Package is working without issues.

Regards,
Suresh Kumar T
Jun 11, 2015 at 9:51 AM
Brilliant. Thanks for letting us know Suresh! Out of interest, does anyone think there will be a solution available for the component at all, just in case Google switches the API off again? We are in the process of planning a SQL upgrade, but doubt it'll be within 12months. Do you think we're safe for a while?
Jun 23, 2015 at 9:55 AM
Hi,

i have the same issue today with the 2008 source.
Anyone else ?

Regards,

Thomas
Jun 23, 2015 at 10:25 AM
Edited Jun 23, 2015 at 10:26 AM
Yes- the issue is back again for me too.

I'm far from an expert, but it looks like this is the cause:

https://support.google.com/a/answer/162106?hl=en

If so, it looks like it's time to switch to a newer version of the component...
Jun 23, 2015 at 10:28 AM
Yes, back for us too.

We're unable to switch to a newer version anytime soon. Is there no other workaround? Is there anyone working on a solution for this?

Thanks
Shona
Jun 23, 2015 at 11:57 AM
Hi Tillman,

did you check if it is possible to implement OAuth 2.0 in the 2008 component ?
Jul 17, 2015 at 8:26 AM
Tillman, many thanks for this fantastic widget.

Any news on the SQL Server 2008 dev? I've tried, to no avail, to open up your sourcecode - what version of VS did you use to create the component?

It would be interesting to learn why you have 2012/2014 versions - why can the widget not work for all versions? (I am non-technical!)

Many thanks again, and look forward to working with this tool again.

Best wishes,

Andrew
Aug 4, 2015 at 8:02 AM
Tillman, I don't suppose you've had any luck?
Ta,
Andrew