System.NullReferenceException when Preview is clicked

Oct 3, 2012 at 4:06 AM

Hi Tillmann:

 I'm really new using SSIS. I start by adding a new data flow task to a SSIS package that works OK to create our DW.

I need to get some ga data and import to  a SQL Server table .

As source I added the GoogleAnalyticSource component with dimension="Month" and metrics = "NewVisits", "VisitBounceRate", "Visitors", "Visits". 

 When I tested the connection is was all ok but I can not preview the ga data.

A null reference exception appears: 

System.NullReferenceException: Object reference not set to an instance of an object.   at SSISComponents.frmGoogleAnalyticsSource.btnQuery_Click(Object sender, EventArgs e)

And the message "not all the dimensions and metrics can be query together" 

Could you please give me some hints what does it happens?

I have another question. In the configuration tab there are two text box, dimensions and metrics that are not included in your screenshots. What do I need to write here? The path name of the xml dimensions and metrics files that were provided with the installation package?

Thank you in advance,

 Gladys

Oct 16, 2012 at 6:20 PM

I'm getting the same response from the latest version (alpha 2); however we have been using the previous 64bit version for months without issues.  

In this case I uninstalled the older version and installed 1.1a2.  Added the object to the toolbox and created a new package that simply pulls a range of time for just Date as the Dimension and Pageviews for the Metrics.  Leaving the default Start and End dates and nothing for the xml lookup files.  

Testing the connection works and by logging in I get a list of Profiles; however just like above the Preview option fails with the same result.

System.NullReferenceException: Object reference not set to an instance of an object.
   at SSISComponents.frmGoogleAnalyticsSource.btnQuery_Click(Object sender, EventArgs e)

Executing the package does return results, so it seems like the problem is just the Preview option.

 

 

Oct 19, 2012 at 12:24 AM

Hi Tillman,

Great work on fixing the new login.

I'm also having trouble seeing previews of the data selection. (same error as the folks above)

Thank you,

Doorag

Oct 30, 2012 at 3:00 PM

This is the same issue that I reported yesterday. I believe your response was that it's fixed in the current version "1.2.0.0". However, that's the version that I'm on.

I love this product, great job on all your work!

 

Jake

Coordinator
Oct 30, 2012 at 7:00 PM

Yes, sorry for the confusion, the bug is fixed in the new version 1.2.0.0.

Cheers,

Tillmann

Marked as answer by Tillmann on 2/15/2014 at 9:02 AM